PrismCore V28.2.7.27 - Current Version

IMPORTANT NOTES ABOUT PRISMCORE V28

SQL 2012 R2 OR HIGHER
A prerequisite is at least SQL2012 R2.  For those users that are enrolled in our ISV program, this upgrade doesn’t cost anything, and in most cases is a simple process.  For those users who want to go from 32bit to 64bit, it will require additional efforts so please contact support for more details.  We strongly recommend Server 2016 64 bit with SQL 2016 64 bit to take advantage of the performance and security offered in those products.  

REQUIRES WINPRISM 27
In order to load PrismCore 28, your store needs to have already had NBC update your servers to WinPRISM 27.  If you are NOT already on a version of WinPRISM 27, you will need to contact IT Support, and they can assist you in scheduling your update.

XP NOT SUPPORTED
Please note, PrismCore 28 does NOT support Windows XP.  If your workstations or registers have XP, you will need to upgrade them to Windows 10 prior to installing PrismCore 28.

INSTRUCTIONS AND RELEASE NOTES

Release Notes - PrismCore v28.2.7.27
Update Instructions for PrismCore v28

DOWNLOADS

SERVER
PrismCore Server 28.2.7.27 Update

ICS WORKSTATION
Workstation 28.2.7.27 Installer
Workstation 28.2.7.27 Silent Installer
Workstation 28.2.7.27 cab

POS REGISTER
WinPOS 28.2.7.27 Installer
WinPOS 28.2.7.27 Silent Installer
WinPOS 28.2.7.27 cab

WPSERVER
WPServer 28.2.7.27 Installer
WPServer 28.2.7.27 Silent Installer